How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12592
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

My Toro model LX420 will operate correctly while, but

Customer Question

My Toro model LX420 will operate correctly for a while, but then will stop and appear to want to go in both directions at once. This will pull the engine RPM down as if it is pulling hard. I replaced both drive belts and it worked ok for about 10 minutes, then did the same thing. I get the impression that something is wrong in the transmission/differential.
Submitted: 1 year ago.
Category: Small Engine
Expert:  JohnF2015 replied 1 year ago.
Do both transmissions do this or just one side?
Expert:  JohnF2015 replied 1 year ago.
I am sorry, you only have one transmission.
Expert:  JohnF2015 replied 1 year ago.
Take a close look at the variable drive pulley on the rear of the machine where both belts fit onto. I am going to guess that either the belts are jumping across the center sheave of the pulley or the bearings in that pulley assembly are going bad as they heat up they lock up or get tight.