How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 13160
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a like new x300 (51 hrs). It will not start. Good

Customer Question

I have a like new x300 (51 hrs). It will not start. Good battery but seems to not be getting any fire to the spark plugs. It has a 17 hp kaw. Is there possibly an in line fuse?
Submitted: 1 year ago.
Category: Small Engine
Expert:  Curtis B. replied 1 year ago.
Welcome to JUST ANSWER small engines, let me try to help you !! If the starter is working, the fuse is good. Have you removed spark plug and verified that there is no spark? Plug grounded to the engine? With twin engine, it is not likely a coil failure, but I do see an oil pressure switch. I could be grounding out the spark. If it as spark, it may be a fuel problem. Do yo hear the fuel solenoid in the carburetor click open as soon as you turn on the key? ???