How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 27492
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Have a 20 HP Briggs vanguard. Will not run unless I remove

Customer Question

Have a 20 HP Briggs vanguard. Will not run unless I remove the air filter housing. Runs great and go to install housing back and will choke off within 30 seconds. remove cover and will crank right back up and run until I try again. Have checked and not pressing on fuel line
Submitted: 1 year ago.
Category: Small Engine
Expert:  Curtis B. replied 1 year ago.
Welcome to JUST ANSWER small engines, let me try to help you !! The carburetor has fuel pump as part of the lower section. It has a pulse hose that comes from the crankcase. There is a vent hose that goes to the air cleaner housing, see if this vent hose is open.If the vent line is plugged or crimped , it could be affecting the crankcase pressure, which runs the fuel pump diaphragm. The air cleaner may be affecting the fuel pump operation!
Customer: replied 1 year ago.

The is one hose on the back air filter housing that goes over to a silver box with ohv on it. It is not crimped or stopped up

Customer: replied 1 year ago.

I can put the housing on and it will run fine until I start to put the screws back in

Expert:  Curtis B. replied 1 year ago.
Remove the vent hose and see if it runs!
Customer: replied 1 year ago.

Same thing, pulled vacuum line from back of breather housing. Mower cranked up ran fine until I went to put two top screws in cover. Starts to run rough and cuts off. Will not crank back. Remove cover and fires right up

Expert:  Curtis B. replied 1 year ago.
I assume the air filter element Is clean?
Customer: replied 1 year ago.

Not even getting to put element back on. Once I put the two screws that hold the housing that is it. On top of the carb there are two ports are hose bibs. One is for the fuel coming from the fuel pump. The other one is just open. Was thinking maybe there was a hose that went there that has come off.

Expert:  Curtis B. replied 1 year ago.
what is full model number of engine?
Expert:  Curtis B. replied 1 year ago.
The open hole on carburetor is vent, it has to be open! Is it open?
Expert:  Curtis B. replied 1 year ago.
Are mounting gasket for carb good?
Customer: replied 1 year ago.

It runs perfect even with the housing and filter on. When I put the long maybe 4inch screws back in to hold the housing in place is when it starts running rough then cuts off.

Is the mounting gasket you are speaking of between the housing and carb. or the carb and engine.

Expert:  Curtis B. replied 1 year ago.
Let me opt out and see if someone else has seen this!