How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26016
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Toro zero turn with kawasaki frv651V; engine starts fine with choke, wants to cut off with

Customer Question

toro zero turn with kawasaki frv651V; engine starts fine with choke, wants to cut off without choke...after long warm up will run, but engine revs; try to use blade and mow, cuts off. changed fuel filter, air filter cleaned, checked flow of fuel pump. still revs or cuts off. spark plugs okay.
Submitted: 1 year ago.
Category: Small Engine
Expert:  Curtis B. replied 1 year ago.
Welcome to JUST ANSWER small engines, let me try to help you !! Run a cylinder test first. loosen the spark plug wires and with engine idling, pull off one wire at a time, if engine dies when one wire is removed, the opposite cylinder is not firing. If both keep running, cylinders are both working. If cylinders are ok, do a through cleaning of the carburetor.
Customer: replied 1 year ago.
I did the spark plug test - but the engine kept running when removing each spark plug wire. it's hard to keep the engine running - some backfiring now as well. I can get it started with full gas, full choke but have to keep it there...but it revs down...almost cuts off...then will rev back up. Or just cut off. I can keep it from cutting off if I manually play with the lever going into the carburetor. I don't have a manual or expertise to clean the carburetor without specific instructions.
Expert:  Curtis B. replied 1 year ago.
http://outdoorpowerinfo.com/repairs/mikuni_carb_15003.asp
Customer: replied 1 year ago.

The carburetor is a Walbro and doesn't look like the directions you sent for the mikuni. I have been out of town but need to get this issue resolved in the next few days.

---------------update------------------

I found another guide to my Walbro carburetor, removed it, disassembled it completely and cleaned it with carb cleaner and used a small wire to make sure all areas were clear. I didn't see anything wrong with it via disassembly, but cleaned all areas anyway. After reassembly, Restarted the mower, but I'm having the same problem. It was easier to get it to the point of running without the choke, but engaging the blade still makes it cut off. After running the engine for a good five minutes, I was able to engage the blade...sounded like it was running great for about 2-3 minutes, then went right back to cutting off. When restarting, it revved (by itself) again, then cut off...same thing when restarting several times.