How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert P Your Own Question
Robert P
Robert P, Small Engine Technician
Category: Small Engine
Satisfied Customers: 631
Experience:  40 years experience in 2 & 4 stroke eng. 6 1/2 years Tech 3 Georgian College Small Motors Division
28648688
Type Your Small Engine Question Here...
Robert P is online now
A new question is answered every 9 seconds

x485 john deere tractor with snowblower attatchment problem.

Resolved Question:

x485 john deere tractor with snowblower attatchment problem. i pull pto switch, it lights up, everything is spinning properly, functioning. when i start plowing snow, it only throws it a couple of feet, and then it quits. Is it an electrical problem? It just seems that the blower has no power at all. When it does run without plowing any snow, it seems weak.  In the fall w/mower deck on it was working pretty hard mulching leaves. 
Submitted: 5 years ago.
Category: Small Engine
Expert:  Robert P replied 5 years ago.

Thank You for using Just Answer , my name is Robert.

There is definitely a switch I would think interrupting the PTO , in the summer 99 % of the time it's the seat switch , try disconnecting it or jumping it , to eliminate the problem , with it not having power, it sounds like the belt possibly not routed properly and going tight enough, also check shear pins .Good luck Robert P

Robert P and 3 other Small Engine Specialists are ready to help you
Customer: replied 5 years ago.

i was gonna replace the seat switch, i looked closer at the seat bracket which showed wear. i put the seat rod through a different hole which seemed to fix a different problem i'v had all summer which was putting parking brake on and getting off the mower and it would stall.

 

like i added before, i worked it pretty hard with mulching leaves in the fall. that last batch before i put on the plow for the winter, it really bogged down and ran slow. with plow on now, pto switch lights up, slow engagement of the plow. It would throw the snow about 2ft. and then would stop. switch still lit up after that, but the plow would not move after that.

so when the blower would move, it had no power.