How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask kingcobra80 Your Own Question
kingcobra80
kingcobra80, Small Appliance Technician
Category: Small Appliance
Satisfied Customers: 5645
Experience:  20+ years repairing various small appliances
32169475
Type Your Small Appliance Question Here...
kingcobra80 is online now
A new question is answered every 9 seconds

My Bissell Proheat 2x is not spraying water the motor runs

This answer was rated:

My Bissell Proheat 2x is not spraying water the motor runs and there is good suction. Model 9200
The Proheat Carpet Cleaners have a small pump located in the front of the machine underneath the nozzle and a rectangular heater located inside the handle assembly. The most common reason they won't spray the solution is due to the heater being plugged. There is also a chance the pump belt is bad or you could have a bad pump.Check the belt first.Generally, Proheat models have two belts a toothed belt that turns the brush roll, and a flat belt that turns the pump. To replace the pump belt it is located in the front on the users left hand side. Turn the machine over and you’ll see a red retainer with 2 screws. Remove the screws and retainer to get to the pump and belts.Check the red pump pulley, it’s located where the two belts are. If that pulley is broken or loose you’ll have to replace the whole pump, the pulley is not available separate.

If the belts and pump pulley are good, move on to the heater. The heater is rectangular and made of metal. It is located in the handle section. You’ll need to remove the screws from the back of the handle to gain access. Remove the tubing from the heater and also the heater cover. There is a chance there will be dirt inside. Clean it out use a paper clip to clean out the connectors where the tubes were connected. After you put the machine back together run white vinegar through it to clean out any remaining dirt inside.

If it is still having trouble after following the above instructions, the pump is bad and will need replaced.
Customer: replied 3 years ago.

I already had checked the belt and it was fine will check the heater now Thanks will fill you in on how this works out


 

ok
kingcobra80 and other Small Appliance Specialists are ready to help you
Customer: replied 3 years ago.

Sorry I work 12 hour shifts and haven't had a chance to work on the bissell I will give you a high rating anyway. Thanks for the help sorry I am so slow!