How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Saturn Technician
Category: Saturn
Satisfied Customers: 24432
Experience:  ASE certified Technician advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Saturn Question Here...
Amedee is online now
A new question is answered every 9 seconds

P0107 MAP error. Running rough. Ground to MAP is good,

Customer Question

P0107 MAP error. Running rough. Ground to MAP is good, supply is 5V good, signal wire is 5V and drops when vacuum supplied. 1999 Satrun SL2 auto 185K miles.
JA: Have you metered out the ignition system?
Customer: No have not.
JA: What is the model of your '99 Saturn?
Customer: SL2 DOHC auto.
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Back probed MAP, all wires are good at sensor. Replaced sensor no change, sent back part. MAP appears to function properly.
JA: Anything else you want the mechanic to know before I connect you?
Customer: That is everything.
Submitted: 24 days ago.
Category: Saturn
Expert:  Amedee replied 24 days ago.

Hello and welcome!

My name isCustomerand I can assist you with your question.

Expert:  Amedee replied 24 days ago.

If the 5 volt reference coming from the PCM is dropping down or missing at any time when the engine is running, then th PCM is either at fault or there is a wiring issue from the PCM to the sensor or a faulty input to the PCM. (intermittant power or ground) causing this condition.

Customer: replied 24 days ago.
I don't believe the reference is dropping, it is constant 5V.
Expert:  Amedee replied 24 days ago.

Ok, I see, then I must have read your post wrong.. sorry

Customer: replied 24 days ago.
5V supply is good, signal wire is at 5V when key is turned. Signal drops as vacuum applied, this is how a working MAP responds.
Expert:  Amedee replied 24 days ago.

Ok, then based on my experience, this is caused by a bad TPS or EGR valve which can confuse the computer if they go bad causing this code.

If all checks out good, the PCM is at fault and will need to be replaced.

Customer: replied 24 days ago.
I HAVE replaced the MAP no change. I have verified the MAP is working properly the issue is elsewhere, likely in wires. The wire harness goes back behind the engine. P0107 means no voltage on signal wire to PCM.
Customer: replied 24 days ago.
TPS replaced already. EGR cleaned, not positive it is okay, EGR ports cleaned.
Expert:  Amedee replied 24 days ago.

I understand that sir.

Have you monitored the voltage on the MAP signal wire going directly into the PCM?

Customer: replied 24 days ago.
voltage on the MAP signal wire going directly into the PCM monitored, it appears okay at the sensor.
Expert:  Amedee replied 24 days ago.

Ok, then yes, the PCM is at fault

Customer: replied 24 days ago.
Thanks but I do not agree. It is very unlikely that MAP goes bad.
Expert:  Amedee replied 24 days ago.

I agree. The MAP does not usually go bad.

Expert:  Amedee replied 24 days ago.

I am not saying the MAP is bad. I am saying that the computer is at fault.

Do you understand?