How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George H. Your Own Question
George H.
George H., ASE Certified Technician
Category: Saturn
Satisfied Customers: 807
Experience:  ASE Master Tech 15+ Years
13574682
Type Your Saturn Question Here...
George H. is online now
A new question is answered every 9 seconds

I have p0050 code. have changed 2 o2 sensors wondering if

Customer Question

I have p0050 code . have changed 2 o2 sensors wondering if there is more that i'm not seeing? Also when driving at highway speeds at 1800-2200 rpm and try to maintain speed on a slight incline the engine stumbles or studders it doesn't pull smoothly
JA: What happens when you step on the gas? Do you notice a rough idle?
Customer: no but if I accelerate hard enough to move through that rpm range it runs fine
JA: What is the model of your '200 Saturn?
Customer: It's a 2009 outlook xr.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: yes I would like to.I mentioned the studdering to a outlook service person he sujested fuel injector cleaner which i did no improvement have also changed two o2 sensors might try cleaning mass air sensor and throttle body
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Saturn Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Saturn
Expert:  david craig replied 5 months ago.

Hi Im david, cleaning the throttlebody and mass airflow sensor is a good idea, also cleaning the idle air control motor and egr valve is a good idea. its a fault off the bank 2 sensor 1 circuitry , so replacing more than that one was not necessary. if cleaning the above mentioned components does not help then we will have to look at the wiring from the sensors connector to the ecm.