How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George H. Your Own Question
George H.
George H., ASE Certified Technician
Category: Saturn
Satisfied Customers: 807
Experience:  ASE Master Tech 15+ Years
13574682
Type Your Saturn Question Here...
George H. is online now
A new question is answered every 9 seconds

My name is ***** *****. Not sure how to word my problem.

Customer Question

Customer: my name is ***** *****. Not sure how to word my problem.
JA: Thanks. Can you give me any more details about your issue?
Customer: I have a 2001 Saturn SL1. the horn didn't work so I replaced the horn, relay, airbag/horn button in steering wheel and fuse. I noticed when I replaced the relay that there was corrosion where it plugs in. I took the cover off the relay box so I could clean the corrosion from the "guts". When I took the cover off Some of the wires came loose and I'm not sure how the were routed.
JA: OK got it. Last thing — Saturn Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: Saturn
Expert:  Randall C replied 10 months ago.

Hello, sorry for the delay, Are you asking as to what wire goes where in the horn relay, just a little confused sorry, please resend details, thanks

Customer: replied 10 months ago.
no. Inside of the relay box that is under the hood has a bunch of copper wires under the cover. I removed all the fuses and relay and took the plastic cover off to get at the corrosion under the plastic plate. When I removed the cover it looks like some of the wires are either broke or not routed where they should be.
Expert:  Randall C replied 10 months ago.

I have access to all diagrams etc but still not following the question so,, can you take picture, upoakd to this post. I have to see what you are talking about. Here is a link to the fuse box under hood, You only spoke of horn relay so still a bit confused

Customer: replied 10 months ago.
ok. I'm going to take a picture and download it. It'll take me a few minutes.
Expert:  Randall C replied 10 months ago.

no rush

Customer: replied 10 months ago.
let me know if the picture came through
Expert:  Randall C replied 10 months ago.

it did and honestly I have never seen this happen,There is no diagram that will show the outline or layout of all the backside wiring that I have ever seen, With this said? I will opt out in case another expert can help, Sorry i could not,Unsure where to go with this one

Customer: replied 10 months ago.
Is there anyone that can help me with this>
Customer: replied 10 months ago.
No need for help now. I got a different fuse box and got it working. Hope I'm not going to be charged for this.