How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Saturn
Satisfied Customers: 23739
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Saturn Question Here...
Dan is online now
A new question is answered every 9 seconds

PO174 keeps showing up I have replaced all emission devices

Customer Question

PO174 keeps showing up I have replaced all emission devices the past 2years intake gaskets and injector o rings this year,, car has 112000 miles, it is driving me nuts
Submitted: 1 year ago.
Category: Saturn
Expert:  Dan replied 1 year ago.

Hello, my name is***** is usually caused by intake gaskets or mass airflow sensor. How long have you been getting code?

Customer: replied 1 year ago.
Been getting code since after last MVR test 12/2014,, mass air has been replaced,,,Intake gaskets have been replaced along with the injector o rings,,fuel press is in spec,,vac is good
Expert:  Dan replied 1 year ago.

Everything has been replaced since 12/2014 and it didn't help? How does vehicle run? Thanks.

Customer: replied 1 year ago.
car runs great
Expert:  Dan replied 1 year ago.

I'm not able to take the phone call right now but someone else may. Was sensor replaced with AC Delco brand sensor?

Customer: replied 1 year ago.
No it was a Cardone reman 11/04/2014
Expert:  Dan replied 1 year ago.

I would recommend replacing with an AC Delco brand mass airflow sensor. Considering it isn't running rough means fuel pump is working, vacuum would cause low idle, and this code is usually caused by a failed mass airflow sensor. Let me know how I goes or if you have more questions. Thanks.

Customer: replied 1 year ago.
I can't do it right now,how would I get back in touch with you
Expert:  Dan replied 1 year ago.

You can comeback to this site and reply the same way you are now. Check the Mass Airflow (MAF) sensor readings on a scanner. At 600 RPM, it should have about 3.5 Grams Per Second (GPS), 1200 RPM 5 GPS, 1800 RPM 8.5 GPS and 2500 RPM 13.5 GPS. Let me know how it goes, thanks.

Customer: replied 1 year ago.
mass air is running in spec,,po306 showed up,checked plugs 2,4,6,#6 smelled of unburned fuel,checked coil pack,looked like possible arcing,put on new coil pack,,also found no vac to fuel press reg,,moved vac line to diff.location,,engine is running great, drove it 120 miles,,so far no codes,,this has been a very frustrating experience
Expert:  Dan replied 1 year ago.

Vacuum line missing from regulator would usually cause high pressure ad make vehicle run rich. Regardless, I'm happy to hear problem is fixed. Thanks for update.