How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Saab
Satisfied Customers: 26253
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
14928985
Type Your Saab Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I purchased a 2004 Saab 93 Aero and hasn't been started

Customer Question

Hey! I purchased a 2004 Saab 93 Aero and hasn't been started check it with the tech2 and it's saying o-bus break detected I did a test on the bus with the tech2 and it says ringbreak just before the icm. Remove the plug behind the icm and there is no red light not sure what to do next
Submitted: 3 months ago.
Category: Saab
Customer: replied 3 months ago.
I also notice red light flickering inside the icm when it's plug.
Expert:  peterpete190 replied 3 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Is there a specific code number that is coming up with this fault here that you can see?

Let me know so we can continue,thanks Pete.

Customer: replied 3 months ago.
No codes
Customer: replied 3 months ago.
Expert:  peterpete190 replied 3 months ago.

Since the ICM was replaced this can be an issue with the wiring to the ICM itself or a connector issue at the ICM needing repaired or replaced.You will have to trace and inspect the wiring running to the ICM to pinpoint the cause here.Once this is done any damage found to the wiring or connections will need repaired.

This is usually the cause with this type of fault here if the ICM was already replaced and did not resolve the fault here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 3 months ago.
Got this message before i did the bus test and got the previous message
Customer: replied 3 months ago.
I know there could of been an issue with the wiring. That is why I sign up here for guidance so I can get help on how to fix the problem?
Expert:  peterpete190 replied 3 months ago.

O.k.,this does sound like a wiring fault leading to the ICM with the first message you received then the fault with the ring break before the ICM.The wiring will still need traced and checked to locate the break in it and then once located repaired from there to resolve this fault here.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.Your 5 star rating is appreciated

Thanks Pete

Customer: replied 3 months ago.
How do I trace the wiring? I trace the fiber optic wiring or and what will the break look like. Where does do trace it two.
Customer: replied 3 months ago.
The light for the ehu is flickering, but there is no ehu because they instal an aftermarket radio in the car
Expert:  peterpete190 replied 3 months ago.

This would be the fiber optic cable/wiring that needs traced.It should be solid all the way through.Did they bypass the fiber optic for the factory radio do you know?

Customer: replied 3 months ago.
No doesn't seem like they did. How do I bypass it to start the car?
Customer: replied 3 months ago.
Fiber optic wire for the amp in the truck not connected and producing light just fine
Customer: replied 3 months ago.
The fiber optic for the factory radio is just hanging like the one in the above picture
Expert:  peterpete190 replied 3 months ago.

O.k.,these do need looped together.This will trick the O system into thinking all is connected and o.k.The picture below is a loop that is used to loop the fiber optics together.I dont show where these can be purchased so you may search online but usually the two cables at the connector will face each other to send the light signals from one cable into the other.

https://www.dropbox.com/s/l5g3e94nge8eg32/con-11-28.jpg?dl=0

Customer: replied 3 months ago.
Where do I plug this?
Customer: replied 3 months ago.
Not sure if I mention that I have another Saab 93 same year with an aftermarket radio instal and works just fine and the loop is not bypass. I check everything else because I all sign up
Expert:  peterpete190 replied 3 months ago.

What usually has to be done is the optic with the light has to loop through the optic that does not have the light shining through it.Does the other saab have the amp disconnected as well?

Customer: replied 3 months ago.
It's the same exact scenario. That's why I am exhausted and came here for answer
Expert:  peterpete190 replied 3 months ago.

Do you now if the other vehicle was reprogrammed at all to not recognize the radio and amp?

Customer: replied 3 months ago.
No. I don't think there is anyway of reprogramming it no to recognize the radio and amp and if there is please tell me, because I have a tech2 and can do that. I replaced the ecu from my other Saab didn't have to program it not to recognize the radio and amp.
Customer: replied 3 months ago.
Let me know if you have the procedures on how to do that?
Expert:  peterpete190 replied 3 months ago.

I dont see a way myself to program with just the Tech 2 but some models have to have the GM computer plugged into the Tech 2 in line with your vehicle to access programming.I dont show a program procedure myself on this here but some can be reprogrammed this way to disable the components that are bypassed.

This is the only thing I can think of here on why this is occuring here.Either this or there is an issue with a break in the fiber optic cabling leading from the ICM.I would follow the ICM fiber optic cabling to see if any breaks or damage is found.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.Your 5 star rating is appreciated

Thanks Pete

Customer: replied 3 months ago.
The tech2 is a GM computer that does all the programming. I have programs a lot of stuffs. If a break is found how do I fix the break?
Customer: replied 3 months ago.
You said trace the wire where does it go after the icm. The computer clearly states ringbreak just before icm. Please advise
Customer: replied 3 months ago.
I didn't notice any break just before icm and the read light is flashing inside the icm and the information center is working, not sure that is even the issue.
Expert:  peterpete190 replied 3 months ago.

The tech 2 does do programming but in order to actually program control units the Tech 2 has to be plugged into GM programming access at the same time it is plugged into your model.I worked with a GM dealer as a tech for 17 years and had to program several models this way.

My info shows the ICM to the EHU then to the CD player and down from there as listed below.

https://www.dropbox.com/s/lst517kbvfctin4/ic-11-28.gif?dl=0

Customer: replied 3 months ago.
I do have the gm programming access to plug in the tech2 , but you saying you don't have the procedures on how to do it. Am I wrong?
Expert:  peterpete190 replied 3 months ago.

Unfortunately I do not show the procedure on how to do this on this model myself.If you would like I can open your question for others here to see if anyone else can assist further just let me know if this is something you would like to do.

Thanks Pete

Customer: replied 3 months ago.
Sure if there is a way to do it I would love to know because everything you are telling me it's not knew to me or I haven't done. I check both cars and they are both the same way but one not working. The optic on the EHU is not hook showing solid red for fiber and the CD player is not hook neither because there is an after market radio installed in the car they no longer there. The other car is like that and works fine
Expert:  peterpete190 replied 3 months ago.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Customer: replied 3 months ago.
Mark is a technician that help someone fix a similar problem. I was trying to get him as my tech
Customer: replied 3 months ago.
Customer: replied 3 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 3 months ago.
Why can't i rate you
Expert:  peterpete190 replied 3 months ago.

Did you want to rate my help?