How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask 350matt Your Own Question
350matt
350matt, Engineer - BEng Hons
Category: Saab
Satisfied Customers: 21356
Experience:  Mechanical Engineer with 20 years experience in the auto industry, 8 yrs in formula 1 engine testing
12772297
Type Your Saab Question Here...
350matt is online now
A new question is answered every 9 seconds

Saab 9000 CS: the abs light is on on my 1996 saab 9000 csI

Customer Question

the abs light is on on my 1996 saab 9000 cs
I replaced the dricer side front sensor the light is still on, The new sensor came but did not include the olastic shield that came out with the origonal sensor so I used the old one - it was clean and in good condition. The light is still on. What else should I check?
Submitted: 1 year ago.
Category: Saab
Expert:  350matt replied 1 year ago.
Normal
0
false
false
false
EN-US
X-NONE
X-NONE
MicrosoftInternetExplorer4
Hello If the ABS light is staying on then this would indicate a fault with the system which shouldn't effect the regular braking performance so the car is still safe to drive. The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious. However with ABS systems 99% of the time its a problem with one of the wheel speed sensors and I'd first check the connections at all four corners first for any signs of corrosion or chafed wiring.The sensor is located in the wheel hub so you'll have to remove each wheel in turn to inspect them all.Also check that the toothed wheel that the sensor points to is clean and free of any debris.you can check each sensor's function by plugging the two output wires into an AC voltmeter and spinning the wheel quite quickly, you should get a voltage signal that increases with rev's. Its possible that the fault is only a bad connection to one of the wheel sensors.This may be remedied by removing each wheel in turn and unplugging each sensor and cleaning the contacts with a squirt of electrical contact cleaner. Then refitting.
Expert:  350matt replied 1 year ago.
Hi
do you still need help?