How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12176
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I am actually having problems with my motorhome electrical I

Customer Question

I am actually having problems with my motorhome electrical I believe I am having inverter problems
JA: How many miles are on the car? Is it an automatic or a manual transmission?
Customer: It is a motor home with 30,000 miles and is a 2005 Monaco Knight
JA: Are you fixing your Monaco yourself? What have you tried so far?
Customer: yes I have checked the ATS switch and it seems fine what it is doing is it is not letting any power into the motorhome like when I am plug into a rv sight it just runs off the battreries and draining them
JA: Anything else you want the mechanic to know before I connect you?
Customer: a month ago the motorhome was in storage plugged into 110v just to run the fridge my batteries had run out of water (they were 10 years old) and I did not know it was having power problems than so checked batteries and were dry so replaced them thought I fixed the problem but no "shore" power working
Submitted: 24 days ago.
Category: RV
Expert:  Robert replied 24 days ago.

Hi my name is Robert...

SO if I understand correctly when you are plugged into shore power the batteries are not charging and you have replaced them???

Robert

Expert:  Robert replied 24 days ago.

Normally if you had an issue with the Automatic Transfer Switch you would not get any AC power into the RV unless you had the inverter ON. IF you have power going into the ATS but nothing coming out then it is the issue, if you have power going in and out of the ATS then the inverter may not be charging the batteries, when you plug into power you should see close to 14 volts at the batteries and it should not be going under 12.5 volts. IF the inverter is not charging go to the inverter and follow the cables, look for a LARGE fuse that is bolted to the frame, make sure it is not blown, if that fuse is blown then the batteries are not going to get a charge via the inverter, if the voltage is the same across the fuse then internal issue with the inverter. Shut the inverter down and restart it if you have not tried so.

Also try running the generator if everything works and the battery is charging then it is not an inverter problem but points towards the ATS... IF you are using any cords or adapters on the main cord get rid of them, plug in direct and see what happens......

Hope this makes sense, please feel free to follow up is needed... Robert

Expert:  Robert replied 24 days ago.

Let me know if you need more help on this, have to run out on a service call soon, will respond if needed when I get back. Please keep in mind I only get credit for helping when you select a rating at the top of the page... Robert

Expert:  Robert replied 23 days ago.

Hi was Just checking in to see if my answer helped??? IF you have more questions or concerns please feel free to contact me...

Robert