How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: RV
Satisfied Customers: 24659
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your RV Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have lost my gauges, (speedometer/tachometer/oil

Customer Question

I have lost my gauges, (speedometer/tachometer/oil pressure/eng. temp/ as well as the a/c and windshield wipers. The headlights still function, along with brake lights, but not the turn signals.
JA: Have you checked the fuses? Have you checked the bulbs?
Customer: All fuses have been checked. None are blown. However, at the fuse blocks in the compartment below the driver's seat the tester indicates there is power to some of the fuses, and not others (the ones that control the above listed items)
JA: What is the model/year of your RV?
Customer: 2001 Marlin by National
JA: Are you fixing your RV yourself? What have you tried so far?
Customer: Yes, so far. Have checked the ignition switch. It is functioning properly. Checked the fuse blocks with meter to see what fuses have power and which don dont
JA: Anything else you want the mechanic to know before I connect you?
Customer: Have changed out the relays for the blocks with new ones, to no avail.
Submitted: 1 month ago.
Category: RV
Expert:  peterpete190 replied 1 month ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

If you have power to some of the fuses but not all of them this can be due to an issue internally in the fuse panel itself with damaged wiring or connection terminals needing replaced.I have seen some corrode internally and cause this fault and in some cases the fuse panel needs replaced.If this is or has been checked and found o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete