How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), RV Mechanic
Category: RV
Satisfied Customers: 44452
Experience:  16 years of experience
2499435
Type Your RV Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

RV on a 2007 E450 super duty went into limp mode after I

Customer Question

RV on a 2007 E450 super duty went into limp mode after I fixed the ground on the two 12-volt deep cycle batteries. Apparently batteries were bad and both started hissing and steaming right away. RV was hooked to shore power. Disconnected and replaced with 2 identical new batteries,
However, did not come out of limp mode.
Will the system reset itself?
Ran fine just minutes before the issue.
Submitted: 1 month ago.
Category: RV
Expert:  Randall replied 1 month ago.

Hi! My name is ***** ***** I can assist you with this. I may need some additional information from you first in order to give a complete answer.

Expert:  Randall replied 1 month ago.

Are you referring to a mode on the inverter/charger? If not, please explain further and I can assist you.

Expert:  Randall replied 1 month ago.

Did you remember to hit the battery disconnect relay switch after changing out the batteries? When you unhook them this goes to default in the "store" position and you need to get the batteries back into the "use" mode by hitting the switch. That may be all that is wrong here.

Customer: replied 1 month ago.
Limp mode is where the engine will not speed up, but you are able to limp along to get it to a shop
Customer: replied 1 month ago.
not familiar with that switch
Customer: replied 1 month ago.
there is a battery disconnect switch just inside the RV door to disconnect the 12 volt system inside the RV
Expert:  Randall replied 1 month ago.

It can mean different things........but, that switch is what puts the batteries back into the loop. On the dash or near the entry door or on the overhead. Most are made by Intellitec and say "Use" and "Store" and there is one for the house batteries and one for the coach battery.

Expert:  Randall replied 1 month ago.

Let me know if that doesn't work.........I don't do engine work in my shop and so I would need to opt out of this and allow another tech to offer something that does.

Customer: replied 1 month ago.
No switch like that on the dash or anywhere in the cab area
Customer: replied 1 month ago.
However, I would say they are back in the loop
Expert:  Randall replied 1 month ago.

All RVs have at least two of those. If the engine starts up, then yes...........they are back in the loop.

Customer: replied 1 month ago.
engine starts
Expert:  Chris (aka-Moose) replied 1 month ago.

Welcome, I'm Chris (aka Moose), my normal schedule online is around lunch and after dinner past midnight.

Different tech here, the other opted out.

Are you able to rev the engine in park?

What warning lights in the instrument cluster are on while its running?

Customer: replied 1 month ago.
engine will not rev in park
Customer: replied 1 month ago.
wrench is lit up and check engine light
Expert:  Chris (aka-Moose) replied 1 month ago.

Thanks,

Do you have a scan tool to see which codes are stored?

Customer: replied 1 month ago.
everything was working fine until I fixed the ground on the onboard batteries
Customer: replied 1 month ago.
I think one of the codes was P2112
Customer: replied 1 month ago.
maybe p2104
Expert:  Chris (aka-Moose) replied 1 month ago.

Thanks,

Both of those are throttle body related. That is why you can not rev the engine.

Try this:

  • Disconnect the starting battery
  • Hold the cables together for 1 minute
  • Use brake cleaner or similar and a old tooth brush to clean the throttle body and blade while held open.
  • Reconnect the battery
  • Start it and let it idle for 2 minutes then see if it will rev and drive.

If this fail then we will need to perform diagnostics.

Prior to completing the mandatory rating at the top of your screen. Let me know if I have not yet provided you with ~5 STAR EXCELLENT~service. Reply and let me know in more detail what you need to be pleased with my help.

Thanks Chris

Customer: replied 1 month ago.
are you talking about the two battery cables in the engine compartment
positive and negative
Customer: replied 1 month ago.
will try this in the morning and let you know
9:20 here and RV is outside
Expert:  Chris (aka-Moose) replied 1 month ago.

Yes I am referring to the battery under the hood used for the chassis, not the RV.

Expert:  Chris (aka-Moose) replied 1 month ago.

Hello again Chris here,

  • Sorry you were not pleased with my help.
  • What would you like to do regarding your question now.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris