How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, RV Mechanic
Category: RV
Satisfied Customers: 8431
Experience:  Work on several type of Rv engine, Trans, brakes
6825259
Type Your RV Question Here...
Wayne is online now
A new question is answered every 9 seconds

Engine Stalling, return from trip, used about 1/2 tank

Customer Question

Engine Stalling, return from trip, used about 1/2 tank during trip and refilled just before getting home, then engine quits in driveway. I do remember a couple of weird quick stalls/studders as we were going down the road returning. Starts sometimes but may or may not stay running. Swapped out both filters that are located in the bay behind road side trans cooler/cover. Power cycled ignition a few time before starting and it ran or about 8 minutes, till I raised the RMP a little bit and it quit. Restarted immediately. Moved back/forward a bit and it ran fine. I can hear lift pump (engine/behind ECM mounted), runs about 30 seconds if I don't start.
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: No check engine light, it may stall when idling or under load. At this point only load is moving around parking area.
JA: What is the model/year of your RV?
Customer: 2004 Monaco Diplomat ISC 330
JA: Are you fixing your Diplomat yourself? What have you tried so far?
Customer: Yes, trying first to fix it. Fuel filter, have charger on chassis batteries to keep them topped. Seems voltage is about 13.5 when running. I have a Silverleaf unit hooked to port under dash, but only just got it setup. When it stalled one time I go an error code in silverleaf that was:
JA: Anything else you want the mechanic to know before I connect you?
Customer: ENG SID 251 50 Power Supply. Per silver leaf support it reads code 251 and adds the Power Supply" text. Can't seem to find what the 50 is
Submitted: 1 month ago.
Category: RV
Customer: replied 1 month ago.
I'm guessing the codes in the Silverleaf would match any in the ECM, but not sure how to get the "Diagnostic" lights to flash using the Diagnostic rocker switch on the dash. Most post says ignition on, then hold diagnostic rocker until lights flash, seems that doesn't do it. Tried rocker switch holding at top and also holding at bottom.
Expert:  Wayne replied 1 month ago.

Hi I'm Wayne

I will help you wit this

what engine do you have in it ??

Customer: replied 1 month ago.
Already in the information about, but ISC 330
Expert:  Wayne replied 1 month ago.

Thank you for that

Sorry I did not see it ,had eye surgery

anyway, what you are describing is the fuel transfer/pick up pump

I suggest to replace that, this is a common issue

Customer: replied 1 month ago.
The fuel pickup pump only runs before the engine starts, and as described above it seems to run as expected before the engine starts. If the engine is running and then it quits, why would the pickup/lift pump be involved?
Expert:  Wayne replied 1 month ago.

Hi

Reason being it runs on and off

has a check valve when calls for fuel, this check valve

often sticks, it is the only way to get fuel to filters and pump

Customer: replied 1 month ago.
you originally said replace inline/limp pump, where is this check valve?
Expert:  Wayne replied 1 month ago.

Hi

I may not have made it clear

the check valve is in the inline transfer/pick up pump

Customer: replied 1 month ago.
The Lift/Transfer pump is mounted behind the ECU and behind an ECU cooling plate. Up against the center area of engine block. The Lift/Transfer is in a short parallel fuel loop with the ECU cooler. So, if the check valve in the Lift/Transfer is a problem the Fuel would still flow unrestricted thru the ECU cooling loop when running.
Expert:  Wayne replied 1 month ago.

Hi

Yes that is correct

do you have that ??

Customer: replied 1 month ago.
Expert:  Wayne replied 1 month ago.

Thank you for that

being that is a interment issue

I still say transfer pump

Customer: replied 1 month ago.
Are other Experts able to see my question, now that you have started in conversation?
Expert:  Wayne replied 1 month ago.

Hi

Yes they can

Customer: replied 1 month ago.
Thanks much for your input Wayne, I'm hoping to get some feedback from others.
Expert:  Wayne replied 1 month ago.

OK,

I will opt-out and put back to the board