How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10326
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I have a Roadmaster InvisiBrake on my Ford 150, worked fine

Customer Question

I have a Roadmaster InvisiBrake on my Ford 150, worked fine for over a year, now the pedal is not being pulled down or the light in the Motorhome not going on when the brake in the motorhomes is applied. The compressor on the invisiBrack makes a humming noise, as it seems to be working, but the brake pedal does not push in. And if I push the brake pedal in truck the red light in Motorhome goes on but will not go off and pedal does not release and is very hard, as I have to start the truck and pull the pedal up to release the brake and make the red light go out in the MH. One time when I was on the road and pressed the brake the red light when on and I had to pull over and go back to the truck to release the brake so I would not burn up the brakes on the truck
Submitted: 1 month ago.
Category: RV
Expert:  Randall replied 1 month ago.

Hi! My name is ***** ***** I can assist you with this. I may need some additional information from you first in order to give a complete answer.

Expert:  Randall replied 1 month ago.

Is this unit still under warranty? It needs to be shipped back for them to inspect and repair. No way for us here to really know what the problem is and because of the importance of this unit to the safety of you and others it needs to be factory repaired or replaced. That is mainly due to liability issues. I will say this is the first time I have heard of this happening on this unit and I have been here on site for over 7 years and have my own shop. Please let me know what it turns out to be. I am adding a link to an RV blog about this unit. Hope this proves helpful. http://www.irv2.com/forums/f85/invisibrake-by-roadmaster-95582.html

Expert:  Randall replied 1 month ago.

I am adding a link to the Roadmaster Customer Service info. http://www.roadmasterinc.com/contact.html

Expert:  Randall replied 1 month ago.

Just checking back in to see if you were able to get some response from Roadmaster about this issue?