How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10274
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

We have a 2006 Class C Winnebago a Itasca. The rear main

Customer Question

We have a 2006 Class C Winnebago a Itasca. The rear main shaft arm on the slide out is broken. We are having trouble locating that part. Can you help?
Submitted: 1 month ago.
Category: RV
Expert:  Randall replied 1 month ago.

Hi! My name is ***** ***** I can assist you with this. I may need some additional information from you first in order to give a complete answer.

Expert:  Randall replied 1 month ago.

Which part is broken and what is the make of your slide hardware? Would a good used one work for you?

Customer: replied 1 month ago.
I am not sure of the manufacture of the part. That is why I went to the Winnebago website. I'm assuming that you would know the manufacture of your slide outs in 2006 on my class C. A good used arm would be satisfactory. It is the arm and not the motor that is broken.
Expert:  Randall replied 1 month ago.

The actuator arm? That is the part the pushes and pulls the room in and out.

Customer: replied 1 month ago.
That part is broken on the end next to the outside.
Expert:  Randall replied 1 month ago.

Those can be purchased used. I just had a customer last week that found one at Arizona RV Salvage and Colaw would be another good source. Also E-bay is a good source for used RV parts. New, this will be expensive.

Expert:  Randall replied 1 month ago.

Just checking back in to see if you were able to resolve this issue or not? If you still need some additional input from me please let me know. Thanks!

Related RV Questions