How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: RV
Satisfied Customers: 26726
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your RV Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have a 90 winn. cheifton that would not start. i put a

Customer Question

i have a 90 winn. cheifton that would not start. i put a charger on it. during that process the neg.side of charger wire got hot and melted. i purchased a new battery, new clamps for charger still would'nt start .checked fuses and reset breakers. the headlights, cig. lighter, dash lights work when the lights on turned on. i do get a clicking sound on the driver side around the fuse box. i need you help. thanks
JA: Have you checked the fuses? The dashboard bulbs?
Customer: yes, not the bulbs.
JA: What is the model of your '90 RV?
Customer: winn-cheiftain
JA: Are you fixing your RV yourself? What have you tried so far?
Customer: yes,checked fuses and restset breakers, new battery, new charger clamps. i've tried to start it many times ,wont strart
JA: Anything else you want the mechanic to know before I connect you?
Customer: yes, after repairing my charger i put the batterty back on charge for 5-6 hours. charger shows fully charged. no start
Submitted: 7 months ago.
Category: RV
Expert:  peterpete190 replied 7 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Trace both positive and negative battery cables from the battery to where they run and connect to and see if any of the cables are found to be shorted or damaged causing this issue here.If a fault is found with any of these cables this will need to be repaired to correct this issue.If the cables are or were already checked and found o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete