How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask EricFromCT Your Own Question
EricFromCT, Ford Technician
Category: RV
Satisfied Customers: 3323
Experience:  20 years dealership experience
Type Your RV Question Here...
EricFromCT is online now
A new question is answered every 9 seconds

I have a2002fordf53 motor home with a v10 motor and all of

Customer Question

I have a2002fordf53 motor home with a v10 motor and all of my gauges stopped working tachometer speedometer fuel oil stopped working all at once is there a fuse that controls all of them and where would it be located
Submitted: 1 month ago.
Category: RV
Expert:  EricFromCT replied 1 month ago.

Hi. There should be a fuse panel up above the drivers feet, or set back a little further near the brake pedal. Fuses 10 and 14 in that fuse panel power the instrument cluster. I would check both of those fuses with a test light to verify power is a the fuses.

Customer: replied 1 month ago.
No help all fuses were good
Expert:  EricFromCT replied 1 month ago.

Ok. It is possible that the instrument cluster is not working. What you need to do next is to remove the instrument cluster so you can access the connectors on the back side. Then check to see if the cluster is getting power and and has its ground. If it does have power and ground, then likely the cluster is no good. Is that something you can do?

Related RV Questions