How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), RV Mechanic
Category: RV
Satisfied Customers: 43928
Experience:  16 years of experience
Type Your RV Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

We have a brand new jayco 19bb and we are dry camping and

Customer Question

Hi there! We have a brand new jayco 19bb and we are dry camping and our trailer will not run any electricity off of its battery
JA: Have you tested the battery with a voltmeter? And can you see if it's leaking or not?
Customer: It's not leaking and it has a full charge
JA: What is the model/year of your RV?
Customer: 2016 jayco feather 7 19bb
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I see in the owner manual that there might be a switch if our model is so equipped to swap from plug in to battery but I cannot seem to located the switch. It says that it could be in an external compartment and the only thing I can find are two wires connected to absolutely nothing. I would love to fix it myself since its late and I have little ones and a wife :)
JA: Anything else you think the mechanic should know?
Customer: Not that I can think of - this is only our second time out in the trailer and our first time with no hook ups - it's literally 2 weeks old
Submitted: 1 month ago.
Category: RV
Customer: replied 1 month ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Chris (aka-Moose) replied 1 month ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

Odds are you do not have the switch you read about in the owners manual. This is most likely going to be a fuse blown or poor connections to the battery or chassis. Have you checked the fuses in the panel? Follow the harness from the battery to the camper, there is often a inline fuse there that could of failed.

This is my 1st answer, but does not have to be my only answer. You the website and myself expect you to have a ~~~5 STAR EXCELLENT~~~ experience with my help. Please let me know if you are pleased by selecting a star rating above or by replying and saying your pleased. Not rating or rating 1-2 stars does not benefit you nor me in any way. Follow up and reply as often and when needed, there is no extra charge to do so.

Thanks Moose.

Expert:  Chris (aka-Moose) replied 1 month ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris

Related RV Questions