How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10274
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I have copied our last conversation bellow. I have change

Customer Question

I have copied our last conversation bellow.
I have change the thermostat and the problem is still the same.
Do you have any other suggestions?
--------------------------------------------------------------------------------------------------Hi I have a 1999 GMC fleetwood pace...
I have a 1999 GMC fleetwood pace arrow. Vin: 1GBLP37F9W3318490
This RV have a Atwood Water Heater I6A-6E serial no 3020.
The heater start but is stop before the water temperatur reach 60 degrees Celius.
I guess, its stop the heating at about 30 degrees cesius.
Do you have an idea where thefailure could be?Regards *****
29 May 2016 09:0829 May 2016 09:33
Randall Randall
RV Mechanic
Are you using LP mode or AC mode? I don't have the model water heater over here, but they all work the same way.29 May 2016 10:15
I dont now what LP/AC mode are.
Could you sedd me some instruction that explain this?
I send you some pictures I hope will help you.
heater 1.jpg
heater 2.jpg
29 May 2016 10:22
Randall Randall
RV Mechanic
See the attached link for a copy of the Atwood Service Manual which is for our models that are very similar. LP is gas or propane mode. AC is for electrical mode (if you have that) I can't tell for sure on the photos. If you have a 12 VDC test light we can do some testing here. IF this has been working fine until now, chances are pretty good that the thermostat is the problem. Those are right under that black foam rubber just above and to the left of the burner. Get back to me and let me know if this was working fine before. May 2016 12:27
I use propan.
Do you have the partsnumber on the themostat?
30 May 2016 03:04
Randall Randall
RV Mechanic
The Atwood part is #91447 and is shown on the parts diagram in that manual link I gave you. Page 36 or 37.30 May 2016 10:06
Could you please explain to me how I replace the thermostate?
30 May 2016 10:08
Randall Randall
RV Mechanic
That black sticky tape comes off and they just clip in there with plasitc tabs. Not hard. Just keep track of the wiring and the thermostat goes on the right. The ECO is on the left, but they look just the same.My goal is to provide you with excellent service. If you are satisfied, please rate me. If you have follow-up questions on this same topic, use the reply box below. To start a new conversation with me on a new topic, request me again.
Submitted: 2 months ago.
Category: RV
Expert:  Randall replied 2 months ago.

That usually would indicate a problem with calcium buildup inside the water heater. Try draining it and flushing all the debris out and see if this improves. Let me know. Thanks!

Customer: replied 2 months ago.
can you please explain how I flush this thank?
Expert:  Randall replied 2 months ago.

Take the drain plug out onn the lower left hand side and run some fresh water through there. Use a probe of some kind to get the chunks out (if any) and when it runs clean, put the plug back in. Be sure and turn it off first and let water cool off.

Customer: replied 1 month ago.
I hav flush the tank with the garden hose that have an bended tip.
I have done this serveal times. No chunks and the water was clean. I have used a camera to look in to the wall inside the tank.
I have an picture of this ( I no it is difficult to see but give it a try)
Have I dont clean it good enough? or is it other ways to do this. Are the other thing that stop the water to be warm? Printcard??Odd Sigurd
Expert:  Randall replied 1 month ago.

Are you using LP or electric mode here?

Customer: replied 1 month ago.
I use LP. Therese is no Electric mode on this heater.
To repeat:its start and burn. The exhaus is warm. Its burn about 1 ouer and still the water is max40 degrees.
I have installed a New termostat. Is There any adjustment?
Hmmmm this wasent easy.....
Expert:  Randall replied 1 month ago.

Have you had the LP pressure adjusted on the tank regulator lately? If the pressure is too low the burner won't heat the water up properly.

Customer: replied 1 month ago.
No. How do i adjust the pressure?
Expert:  Randall replied 1 month ago.

That has to be done with a manometer. Most RV shops would have one, but over there it may be a gas company. You can take it off and into them. Or a new one shouldn't be that expensive.

Expert:  Randall replied 1 month ago.

Since I didn't hear back from you I am wondering if you were able to resolve this issue or do you still need some additional input from me here?

Related RV Questions