How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, RV Mechanic
Category: RV
Satisfied Customers: 8761
Experience:  Work on several type of Rv engine, Trans, brakes
6825259
Type Your RV Question Here...
Wayne is online now
A new question is answered every 9 seconds

I have a 1996 Winnebago motor home on a Chevrolet frame with

Customer Question

I have a 1996 Winnebago motor home on a Chevrolet frame with a 454 ci engine. A couple of weeks ago we took a trip and after the engine got hot the "service engine soon" light came on and the transmission lost passing gear. The transmission also shifted VERY hard from low to second, so we stopped for about 15 minutes to let the engine cool. When I re-started the engine the light was off and the transmission functioned normally. I had the radiator system & transmission flushed and installed new fluids.
We recently went on a 600 mile trip and the check engine soon light came on when the engine got hot so we stopped for about 15 minutes to let the engine cool. When I re-started the engine, the light was off and the transmission functioned normally. This happened the next day also. The third day after stopping for the night the engine light was off and the engine/transmission ran perfectly for the last leg of our trip, about 150 miles. The outside temps were in the 80s all 3 days. This motor home sat unused for several years before we bought it. I have had it to two truck mechanics. One thinks the torque converter is bad, another thinks the cooling system was partially plugged because it sat unused for so long and on my third day it finally cleared out causing it to run normally. What do you think?
Submitted: 6 months ago.
Category: RV
Expert:  Wayne replied 6 months ago.

Hi I'm Wayne

I will help you with this

That is a good story , and good info ,Thank you

My thoughts are to replace the radiator and trans cooler

that it sat for a long period of time

Reason being is gunk. Junk settlee into them small tubes of the

the radiator and cooler , flushing is not going to clear this out

needs to be roded or replaced, But shops do not do that any more

not cost effective

so I suggest you replace them

I hope this helped you

Hi. If this helped you,

please remember to rate my answer 3 or more stars.

If more info is needed, use the reply button -

NOT THE POOR/BAD SERVICE

Customer: replied 6 months ago.
Thanks for the answer, but if that's the case then why did it run in the normal range the third day without any problems and never overheated?
Expert:  Wayne replied 6 months ago.

Hi Thank you for that

I was just going by your info,

I can not see it or be there, you are my eyes,

you did not mention that it ran good on the 3rd day

but you can rest assure it will happen again, it is just not going to go away

I suggest you take the steps , to resolve the issue

so not to spoil a Vacation/Trip

Hi. If this helped you,

please remember to rate my answer 3 or more stars.

If more info is needed, use the reply button -

NOT THE POOR/BAD SERVICE

Customer: replied 6 months ago.
Sorry Wayne but I did say it ran fine on the third day. See the fifth sentence from the bottom. I can't say that your answer was helpful at all. You said "your thoughts" are........ I paid $33 for your thoughts when I expected an analytical answer? That is not acceptable.
Expert:  Wayne replied 6 months ago.

Morning

When I use the Phrase " My Thoughts are ", that is like me saying this is my answer,

I used that Phrase a lot, Maybe after 34+ I should stop using it

My answer is , to replace them both, or at least the radiator

It is up to you, that is my answer

Wayne