How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10329
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I have a Newmar mountain Aire 2005 model 4016. I have power

Customer Question

I have a Newmar mountain Aire 2005 model 4016 . I have power to my breaker box and all breakers have power but nothing works . My smart ems is not lit up tho ????
Submitted: 4 months ago.
Category: RV
Expert:  Randall replied 4 months ago.

What is the make and model of your EMS system?

Customer: replied 4 months ago.
Itellitec
Expert:  Randall replied 4 months ago.

What is the model or part number? Did you check the fuses on the controller module?

Customer: replied 4 months ago.
Fuse to ems is good . It is a 50 amp smart energy management system model 900 by Itellitec.
Expert:  Randall replied 4 months ago.

There are fuses ON the control module..........check those.

Expert:  Randall replied 4 months ago.

When I get home from work soon I can grab a manual and diagram for you on this system.

Customer: replied 4 months ago.
The fuse marked ems in the fuses next to the breaker box is good . When I take that fuse out a green light on a board below the breakers goes out .
Expert:  Randall replied 4 months ago.

Yes, I get that......but, there are fuses ON the control board AT the module as well.

Customer: replied 4 months ago.
Where is that at ?
Customer: replied 4 months ago.
i have looked all over the RV and cannot find the ems module . Any suggestions? My Rv is a 4016 model
Customer: replied 4 months ago.
Ok I found it . 1 5 amp fuse and it's good .
Expert:  Randall replied 4 months ago.

I will be home in about an hour and will try to get you a manual for testing.

Expert:  Randall replied 4 months ago.

See the attached link for troubleshooting this. Print this out so you have it. Let me know if you need more help here and what you find. http://ww2.justanswer.com/uploads/michaelreush/2012-04-28_033135_intelletic_ems_service_manual.pdf