How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12139
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2007 tiffin allegro open road, 32 footer. Only

Customer Question

I have a 2007 tiffin allegro open road, 32 footer. Only 6,300 miles on it and barely used. We just bought it two weeks ago. We ended up taking it on a long trip out first time out. While we were on our trip, the Atwood levelegs started beeping and highlighting back driver side as an error. I can't understand why. And don't know how to really fix it. When we returned from our trip, I noticed that the slide on the drivers side is not flush anymore. It's flush on the top, but not as it gets to the bottom. 1) could this be an easy fix? And 2) are the levelegs and slide not being flush possibly related? Any help or guidance will be much appreciated.
Submitted: 4 months ago.
Category: RV
Expert:  Robert replied 4 months ago.

Hi my name is Robert..

I doubt the two are tied together, it sounds like the room is out of adjustment and I would let a shop do any adjustments because you can actually make things worse if it is not adjusted properly. IF the room is not going in all the way on the bottom make sure nothing is blocking it from shutting all the way.

The jack issue is telling you there is an error for that jack. Click HERE and see troubleshooting sequence and see if you can get that to go out. Check your connections at that jack and the control box for the jacks, make sure nothing is loose or any rubbed wires etc.... Hope this helps some...... Robert

Expert:  Robert replied 4 months ago.

Hi... Was just checking in to see if my answer helped???? IF you have more questions or concerns please feel free to contact me....

Thanks... Robert