How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12788
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a tecma toilet that will not flush. There is power

Customer Question

I have a tecma toilet that will not flush. There is power from the batteries to the controller 12.8 volts however, the water level indicator is not lit. The flush buttons however are lit.
JA: Do you have the trouble code? Do you have a code reader or scan tool?
Customer: No I do not have a trouble code.
JA: Not a problem. You can work with the RV Mechanic to figure that out. What year is your Volts?
Customer: Volts?
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes - I have checked all of the connections to the controller and they are all fine. I have no power to the solenoid.
JA: Anything else you think the mechanic should know?
Customer: Not at the moment'
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the RV Mechanic about your situation and then connect you two.
Submitted: 9 months ago.
Category: RV
Expert:  Robert replied 9 months ago.

Hi my name is Robert....

Click HERE and have a look, if you have power at the controller and not to the solenoid then I would suspect the controller is bad, I would also verify that you do not have voltage on the motor wires for the macerator, if you have voltage on them the impeller on the macerator might be plugged up, have seen that a more then a few times with this toilet where the impeller gets blocked and it will not flush but I believe it still should be putting water in the toilet and the control box feeds the DC voltage for the solenoid so I suspect the solenoid is at fault but I would verify to see if the pump is getting voltage or not, if so I would pull the toilet and make sure the impeller is not clogged.... Hope this helps some, IF you have more questions or concerns please feel free to contact me.... Robert

Expert:  Robert replied 9 months ago.

HI... was just checking in to see if my answer helped??? Please feel free to contact me if needed..