How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Reush Your Own Question
Michael Reush
Michael Reush, RV Technician
Category: RV
Satisfied Customers: 3249
Experience:  Serving the rv industry since 1977
Type Your RV Question Here...
Michael Reush is online now
A new question is answered every 9 seconds

Have replaced a failed Atwood gas/elec 10 gal water heater

Customer Question

Have replaced a failed Atwood gas/elec 10 gal water heater with an Atwood 10 gal gas only unit. The first tank heating cycle went fine, but then on the second the igniter clicks, but continues after the flame starts for a few seconds and then the flame shuts down.
Submitted: 3 months ago.
Category: RV
Expert:  Michael Reush replied 3 months ago.

Hi, this winter I installed 2 different gas atwood waterheaters, and they both had this symptom, The problem is that the control module is bad, and will need to be replaced. As it is new it will be done on warranty. You need to contact an atwood warranty station. Quite honestly, I paid for the new controls in each instance as it takes a week or better for atwood to send the part. wishing you well Michael......please get back to me if you would like to discuss this further