How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12163
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

My rv hot water heater will not turn on. I have both options

Customer Question

my rv hot water heater will not turn on. I have both options electric and gas option to heat
JA: HHave you checked the coolant level? Has there been any leaking from the hoses?
Customer: no leaking
JA: What is the model/year of your RV?
Customer: 2015 holiday rambler vacationer
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I checked the breaker and the fuse and both appear to be ok
JA: Anything else you think the mechanic should know?
Customer: I don't think so
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the RV Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: RV
Expert:  Robert replied 5 months ago.

HI my name is Robert...

What is the make and model of the water heater??? Also when you try and run it on LP do you hear any noise at all?

Robert

Customer: replied 5 months ago.
I don't hear any noise as though it was trying to light on LP. Last time it was working and now it is not. Looks like an Atwood10 gallon
Expert:  Robert replied 5 months ago.

OK

Go to the outside access and locate the circuit board, pull the connector and then clean the contacts on the board with an eraser. Sometimes this is a weak link. IF that harness has voltage on it when you have the switch ON for LP or Electric it is most likely a problem with the board. The water heater should have a high limit for BOTH the LP and AC side so it would be rare for them both to fail. Normally the high limit for the LP side is on a brown wire, the wire would have a clear shield over it, that is a one time fuse, so if you see that make sure you have continuity through it or it does not look burnt.

It also could be the circuit board assuming you have voltage on the harness, most RV stores can test the board with a special tester and see if the board is at fault, they do fail. IF your unit is still under warranty I might consider having a shop take a look. IF you still need help please get me the model of the Atwood, should be on a sticker under the outside access panel. Hope this helps some......

IF you are satisfied with my efforts please feel free to select a rating at the top of the pafge, it is the only way I get credit for helping... Robert

Expert:  Robert replied 5 months ago.

HI.... Was just checking in to see if my answer helped???? IF you have more questions or concerns please feel free to contact me..... Robert