How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10274
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

Fleetwood Flair has good chassis battery but no power to

Customer Question

Fleetwood Flair has good chassis battery but no power to ignition, dash or head lights. Power flows to a box that has 03200 printed on it. It has two small wires and no power on the other side.I would think the other side should have power. Is that correct?
Submitted: 4 months ago.
Category: RV
Expert:  Randall replied 4 months ago.

That sounds like the battery disconnect solenoid. And when you want the batteries "in the loop" you need power flowing through that. Perhaps the switch is not in the correct position. You want to hit "use" on the control button. Check that first and then get back to me if we need to do some testing. All follow ups are included in our fee.

Expert:  Randall replied 4 months ago.

Just checking back in to see if you were able to resolve this or do you still need some additional input from me here?