How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert, RV Mechanic
Category: RV
Satisfied Customers: 11955
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

Beaver patriot thunder 2005. plugged into a friends 30 amp

Customer Question

beaver patriot thunder 2005. plugged into a friends 30 amp forgot to turn off one of the two A/C units it popped like any fuse sound does. we can only run the ac now on generator. the Aladdin camera and motor home stats are not working even on generator. The Aladdin system radio works shows stations but no computer stats on RV are not appearing. we checked fuses in the bedroom there all good? help please
Submitted: 4 months ago.
Category: RV
Expert:  Robert replied 4 months ago.

Hi my name is Robert.....

The Aladdin system part might be hard to answer, but right now you can only run one AC unit off the generator? If that is the case go to the generator and make sure there is not a breaker tripped, most generators will have two breakers. Go to the inverter and make sure you did not trip a breaker on it, most inverters will have one or two breakers. You could also try and plug into a 50 amp service and see what happens, if the AC unit does not work on a 50 amp service OR on the generator then there is an issue with it, could be a number of issues, bad capacitor, circuit board etc.

The Aladdin question is a bit more difficult, that is something only Monaco used, IF I recall correctly there may be a reset button for that in one of the overhead cabinets, but I think that was only for some years. I might try and disconnect the chassis battery and see if that resets it. After that I would call Monaco/HR tech support and see if they have an ideas for you, they do have tech. support for customers..... IF you have more questions or concerns please feel free to contact me... Robert

Customer: replied 4 months ago.
we already paid 32 and it didn't work maybe a rewording of question or phone call(###) ###-#### ***** don't mind paying but not for this kind of scam and paying over and over. I was suppose to be able to ask more question for that 32.00 for the trial
Expert:  Robert replied 4 months ago.


I do not handle the payments or money at all, I only get credit when you select a rating, click HERE and they can assist you. I have helped over 10K happy RV owners in the last 7 years and it is a good site, I am sure they can help you out...

You can follow up with me on this question as much as you like, there is no time limit and you are not getting charged each time you respond....


Related RV Questions