How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert, RV Mechanic
Category: RV
Satisfied Customers: 11962
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

Have you seen my question?

Customer Question

Have you seen my question?
Submitted: 4 months ago.
Category: RV
Expert:  Robert replied 4 months ago.


I have responded to two questions already regarding this once again is my reply below......

This sounds like a faulty solenoid valve, if the solenoid valve was leaking it would do this, the jack could run up. The solenoids will be near the pump/manifold, each solenoid will have a set of wires going to it, you will have extend and retract solenoids. On the end of the solenoid would be a T handle OR 1/4 nut, make sure they are all tight, if one was opened some it would allow the jack to run up.

What you can try next is swap the solenoids, have someone run the jacks while you feel the solenoids, you will feel the solenoid click so then you can swap them and see if the problem goes to another jack OR when they are up if the jack starts to come down. IF you do try and swap the solenoids make sure you open all the 1/4 nuts on the solenoids (or T handles) for the leveling as you need to take the pressure off the system, open them about 5 turns.

Hope this helps really sounds like a solenoid...

IF you have more questions or concerns please feel free to contact me, IF you are satisfied with my efforts please feel free to select a rating, it is the only way I get credit for helping.... Robert

Expert:  Robert replied 4 months ago.

Did you receive my answer?

Related RV Questions