How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., RV tech - emphasis on gensets
Category: RV
Satisfied Customers: 14485
Experience:  RV tech since the beginning of the millenium.
19372534
Type Your RV Question Here...
Hank F. is online now
A new question is answered every 9 seconds

Does my general np50g rv have its own battery supply inside

Customer Question

Does my general np50g rv have its own battery supply inside the housing unit
JA: Have you tested the battery? Is the battery fluid low?
Customer: When I try to start the unit it just makes a clicking sound ,does it use its own battery for starting
JA: What is the model/year of your RV?
Customer: 1994 Chevrolet Gulfstream sun voyager
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Nothing
JA: Anything else you think the mechanic should know?
Customer: Yes I'm out in the mountain in Scotland have no power
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the RV Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: RV
Expert:  Hank F. replied 5 months ago.

Hello, my name is ***** ***** I am going to assist you with this.

The genset does not have an internal battery. It runs off the battery in the RV, usually the house battery. Rarely you will see it connected to the chassis battery.

The clicking sound you are hearing is a sign that the genset is not getting enough battery power to run the starter.

The first thing to do is to check your battery cables, both at the battery, and at the genset, and make sure all connections are clean and tight.

If the cables are not the problem, you need to take the battery in and have it load tested.