How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gene Your Own Question
gene
gene, RV Mechanic
Category: RV
Satisfied Customers: 1100
Experience:  28 yrs exp in the industry
19317657
Type Your RV Question Here...
gene is online now
A new question is answered every 9 seconds

I have a 2014 JayCo Flight Swift. While waiting generator,

Customer Question

I have a 2014 JayCo Flight Swift. While waiting for my generator, the battery ran dry and the water stopped coming through the faucets. With the generator running and the water tank filled and the pump switched on, still no water. The little light next to the pump switch does not come on but the switch light does.
JA: How many miles are on the car? Will the battery hold a charge?
Customer: It is stationary and no car attached. I am living in it I til my home is built.
JA: Are you hoping to fix this yourself?
Customer: I am hoping it is something easy as I live in the middle of the boondocks. I drove 22 miles to get internet access.
JA: Is there anything else important you think the RV Mechanic should know about your RV?
Customer: I have only had it for 1 month and everything except a couple of lights work.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the RV Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: RV
Customer: replied 1 year ago.
The manual says it has a bi-pass pump, but not where it is. Does it need primed or something? It is a 198 RD camper.
Expert:  Randall replied 1 year ago.

It may need priming if you ran it totally dry. And if it won't come on then check the fuse on the positive lead or in your load center. It may not be getting power. I will make a phone chat offer for you in case that might be more helpful here.

Expert:  Randall replied 1 year ago.

Just checking back in to see if you were able to get this resolved or do you still need some additional input from me here?

Related RV Questions