How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10272
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

Got a dometic 2652 americana, just put in a new circuit

Customer Question

got a dometic 2652 americana, just put in a new circuit board, electric and gas fire, no cold
Submitted: 4 months ago.
Category: RV
Expert:  Randall replied 4 months ago.

Is the fridge on and just not cooling? Open up the outside inspection cover and check the flue area. Is it hot or not?

Customer: replied 4 months ago.
it is hot at the heater, and when of gas flame is on, no cold in fridge
Expert:  Randall replied 4 months ago.

Is the cooling unit making any noise? Or is there any yellowish debris around the base of the burner? Ammonia smell? Any of those would indicate a cooling unit that is failing. The "fix" is a rebuilt cooling unit by

ATCO America or a new fridge. The rebuilt units have a 2 year warranty and are galvanized so they last for many years. I like those better than a new one. IF you operated the fridge out of level it may have a blockage inside and that ruins them as well. Hope that explains this, but please get back to me if you need more. All follow ups are included in our fee.

Customer: replied 4 months ago.
none of the above, always balanced, this happened weekend before last saturday into sunday morning working fine, sunday evening working on gas only check gas fight kept comming on, i would reset and a couple minutes light would keep doing this after reset, have the same fridge in a different rv and the same thing was happening so i bought a new board and it now works fine so i bought a board for this one, it cycles perfectly between gas and electric but no cold ???
Expert:  Randall replied 4 months ago.

If the flue is hot and not cooling then the cooling unit is suspect. Unplug the thermister (2 wire lead) in the upper left hand corner of the board and let it run and see if there is any change.

Customer: replied 4 months ago.
just pulled out thermister, 10 seconds later heard a click so something happened, checkedthe electric element it is hot galvanized unt around it is warm, cooling lines are room temp looked up atco, about how much for this and can I put it in myself and does it come charged?
Customer: replied 4 months ago.
how long do I wait to check
Expert:  Randall replied 4 months ago.

I would turn it off for a few hours first and then turn it back on again and let it run for about 4 hours. If it won't cool it needs to be replaced. And yes, the ATCO units come charged and ready to install. Not that hard if you are handy with tools. Let me know how the test comes out. I get $899 for this job in my shop so ask around. Many shops won't do this job.

Customer: replied 4 months ago.
took off the thermister as you said now it is 18 in freezer and 62 in fridge and dropping, is it a faulty thermister?
Expert:  Randall replied 4 months ago.

Perhaps........put the end into a glass of ice water and take an ohms reading on the plug. It should read about 7K to 10K ohms after 5 minutes. If that tests out good, then it may be the control board. Wait for the 4 or more hours and see what you have. Zero in the freezer is what you want to see.

Expert:  Randall replied 4 months ago.

Just checking back in to see if you were able to get this resolved or so you still need some additional input from me here?

Related RV Questions