How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12141
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2013 Heartland 4100 and I started having problems

Customer Question

I have a 2013 Heartland 4100 and I started having problems with the power being off thought it was my supply turns out it seem to be the plug on the end of the cord I didn't replace it but adjusted it a bit so it would lock but as i moved the plug around i could hear a loud clicking sound my guess thats the transfer switch so now the only ac plug that works in the camper is in master bedroom for the tv and the bed room air works and all of the lights frig ,microwave work but the washer and dryer do not
Submitted: 6 months ago.
Category: RV
Expert:  Robert replied 6 months ago.

Hi my name is Robert....

Do you have a 50 amp cord, if so then you could have a bad cord, a 50 amp service is 2 120 legs coming in to the unit. IF you were missing one leg then some AC powered items would work and others would not. IF you have a generator then you have a Transfer Switch. If everything works when you using the generator then it has to be the cord or a loose connection at the transfer switch. IF you have the same issue on generator power check all your breakers inside and make sure you do not have a GFI that is tripped, the GFI would have a test and reset on it... IF you have more questions or concerns please feel free to contact me.. Robert

Expert:  Robert replied 6 months ago.

HI.... I see you have not selected a rating, if you need more help please let me know....

Robert