How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gene Your Own Question
gene
gene, RV Mechanic
Category: RV
Satisfied Customers: 1100
Experience:  28 yrs exp in the industry
19317657
Type Your RV Question Here...
gene is online now
A new question is answered every 9 seconds

I have a 2011 Work and Play. Arrived at my destination to

Customer Question

I have a 2011 Work and Play. Arrived at my destination to hear my smoke alarm going off. I turned off my propane and switched my fridge to AUTO, aired out the trailer. The alarm stopped, but I lost all power. Running lights were not working. Breakers were fine, but the two MAIN 30 amp fuses were no good. Replaced them and my running lights are working again, but nothing else. No lights, no monitor, and the electric jack isn't working.
Submitted: 6 months ago.
Category: RV
Expert:  Randall replied 6 months ago.

Did you just hook up the battery(s) before you left? It sounds like you have the polarity wrong OR the converter just shorted out. One or the other here would seem to be the problem based on what you told me. OR another place is shorted out and caused you to lose power and the short was setting off the alarm. Get back to me with some more information and we can sort this out.

Expert:  Randall replied 6 months ago.

Just checking back in to see if you were able to get this resolved or do you still need additional input from me here?