How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12370
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have 2001 holiday rambler motorhome admiral with a norcold

Customer Question

HI I have 2001 holiday rambler motorhome admiral with a norcold ref serial # ***** model Lrim--group 10207 that will not shut off unless I pull the red wire on the black box on the back side of the unit it works great other than that thanks Gary
JA: Sometimes things that you think will be really complicated end up being easy to fix with RV. The RV Mechanic I'm going to connect you with knows all the tricks and shortcuts. Are you hoping to fix this yourself?
Customer: Yes thanks I do own a repair shop ( auto) but we are in remote area in Mt thanks Gary
JA: Great! What have you tried so far?
Customer: nothing
JA: Is there anything else the RV Mechanic should be aware of about your RV?
Customer: No
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the RV Mechanic about your situation and then connect you two.
Submitted: 7 months ago.
Category: RV
Customer: replied 7 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Robert replied 7 months ago.

HI my name is Robert...

This is going to be an issue with the circuit board or upper control panel inside. To start go unplug all the connectors and make sure they are clean and tight, and no wires have come out of the connectors. I have seen this only twice before on the same model and it ended up being the lower circuit board on one and a wire that came out of the harness near the board on another. The display inside could also be at fault but you are limited on testing. I can see if there is any troubleshooting for that... Hope this helps, IF you have more questions or concerns please feel free to contact me...Robert

Expert:  Robert replied 7 months ago.

I took a look in the service manual and there is nothing for this issue you are having. I would check all your wire connections very carefully, check them at the circuit board outside and then at the control panel inside, make sure no wires have come out of the connectors. After that I would replace the lower board, from my experience it would be an issue with the circuit board. IF the board does not solve the issue has to be the display panel.

My goal is for you to be satisfied with my efforts, IF you would like to try another expert please let me know, I only get credit when you select a rating... Robert

Expert:  Robert replied 7 months ago.

Hi I see you have not selected a rating, if you still need more help on this please feel free to contact me... Robert