How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: RV
Satisfied Customers: 24718
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your RV Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have 3 problems. My pop-up is a 2010 2560G. #1. The roof

Customer Question

I have 3 problems. My pop-up is a 2010 2560G.
#1. The roof AC unit - Dometic 579 Brisk air or 590 or 595 (including heater) does not function properly. It was working fine - cooling - then suddenly stopped - i.e. it was functioning when it stopped working. When I move the "temp knob" I can hear it "click" - as it moves past the ambient temperature. So I believe the unit is getting power - and it is not a "main" fuse issue. However, when I turn the "select function" (air-fan-cool-heat-etc.) knob - nothing happens - i.e. no fan, no cool, etc. Is there an internal fuse, is it a switch? ETC? What should I investigate?
#2. There is a hinge on the cooktop cover that has broken. It is screwed into the "counter" and rivited to the cover. Where can I obtain another hinge?
#3. My wife left one "rear clamp" attached while she tried to raise the top. When she discovered that - she "lowered" the top, unclipped the clamp, then raised the top. The rear of the top - at "the proper extension" is 2" lower than the front of the top - and is now not high enough to put in place the "security brace". How do I "adjust" the rear height?
I am pretty handy with things, but don't know where to start.
Thank you for your help.
Mike
Submitted: 6 months ago.
Category: RV
Expert:  peterpete190 replied 6 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. #1 this may be an issue with the blower fan itself as it may have failed.The switching may be the other components switching from heat to defrost etc. but the fan may have failed requiring servicing or repair.This will have to be tested/checked further to be sure of the cause and is best done by a dealer or repair center that works on this model here. #2 Usually a component like a hinge like this here has to be obtained from a dealer or service center that works on this model here.I would speak with one of them to see if they can obtain this for you. #3 There may be a bent or damaged guide or bracket that caused the 2 inch difference here.I would inspect for any bent or damaged components needing re shaped or replaced to correct this fault here. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 6 months ago.
None of these 3 answers is acceptable. I already knew these obvious things. Please provide detail as to how to resolve.
Expert:  peterpete190 replied 6 months ago.
Unfortunately this is all of the info I have on this here myself.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.Thanks Pete