How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gene Your Own Question
gene, RV Mechanic
Category: RV
Satisfied Customers: 1100
Experience:  28 yrs exp in the industry
Type Your RV Question Here...
gene is online now
A new question is answered every 9 seconds

I have a 1983 4 burner Wedgewood RV oven that is not heating

Customer Question

I have a 1983 4 burner Wedgewood RV oven that is not heating properly.
The pilot stays lit but the only time the oven burner ignites is when the control is set
to 500 degrees or higher. The oven burner then turns back off again before the oven
gets to 200 degrees.
Since pilot stays lit I'm assuming the thermocouple is OK. That leaves the temperature probe or regulator.
I also cleaned and brushed things off around the pilot and oven burner. Problem is that
the oven never gets up to temperature.
Any suggestions?
Submitted: 5 months ago.
Category: RV
Expert:  Randall replied 5 months ago.
You might check the LP pressure at the tank regulator. I can tell you that parts for this are almost non-existent any more. If it is the oven thermostat that may be tough. Attach a photo of that to your post and I can take a look at my old stock.
Customer: replied 5 months ago.
You may be right about the LP tank regulator. I just replaced a leaky one before we started having problems with the oven.
On a side, can you tell me what the bare wire does that is attached to the oven temp regulator on one end and is attached on the other end to the thermocouple mounting bracket. Possible static electricity preventer or something?
Expert:  Randall replied 5 months ago.
That sounds like the sensor wire for the thermostat. Can you attach a photo of that part of this so I can see it?
Customer: replied 5 months ago.
Hi Randall
Thanks for the help so far.
Well, I'm beginning to figure this thing out a little better.
The wire I was asking about is actually the temperature probe wire to the oven thermostat. So I know what that is.
I did replace the existing single stage gas regulator on the LP tank with a new 2 stage unit yesterday but it didn't help my oven's heating problem.
The problem is that the thermostat is able to ignite the oven burner, but only if you turn the thermostat to at least 450 degrees or higher. The thermostat works as it should by increasing the gas to the pilot which in turn increases the heat at the thermocouple which then turns on the gas to the oven burner. That works great. Then burner will run until the oven temp gets to about 200 degrees and the thermostat turns over burner off again. The thermostat thinks the oven is 300 degrees hotter than it actually is. I'm pretty sure the pilot lite and thermocouple are working fine.
After listening to you and from all the experiments that I did, I think my oven thermostat is kaput.
And I have a part number that was both stamped on the part and listed in the origninal Wedgewood parts list that I have .
I need a:
39-02262 Thermostat (ELO) - W/O Top Pilot
Do you know where I can locate one?
Expert:  Randall replied 5 months ago.
I need a photo and maybe I can match up something.
Customer: replied 5 months ago.
Here's some pictures. Good luck.
Expert:  Randall replied 5 months ago.
Let me see what I can find..........

Related RV Questions