How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: RV
Satisfied Customers: 24730
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your RV Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Onan EC30 command center question. I have a 2008 NRV

Customer Question

Onan EC30 command center question. I have a 2008 NRV Pacifica 40e with an Onan QD 8000 Genset connected with factory installed EC30 command center. Coach has Two AC units and an LP furnace. All HVAC units work properly in MANUAL and SHORE POWER modes.Issue: when in AUTO mode, generator isn't receiving calls from HVAC. I have checked out the setup features and SAFETY, GENSTART both respond but when I test for the HVAC1, HVAC2, and HVAC3 I get no response. I have a single thermostat that controls all functions for both AC units and the Furnace. I've tried cycling thru the menus in different ways.Where should I start looking? To trouble shoot this problem.
Submitted: 6 months ago.
Category: RV
Expert:  peterpete190 replied 6 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. This may be an internal electrical fault with the command center itself not sending signals to turn this on when commanded on.I would have this tested further (and this may require a service center or dealer that works on this model to do this testing) to see if the command center needs removed and replaced or repaired as well as to check for any wiring issues needing repaired. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 6 months ago.
Is the "brain" for the command center all contained in the small console with the buttons or is there another box somewhere? If sell contained, it seems that the easiest fix would be to replace that console?
Expert:  peterpete190 replied 6 months ago.
It should be part of the console with the buttons but I would have this tested further first to make sure this is the cause here and also to make sure there isnt a separate brain/ecu for this.I think it is all one assembly though. Let me know if you need anything else and feel free to rate my help here. Thanks Pete