How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10270
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I have a 2016 winnebago Navion, sprinter chassis, that has

Customer Question

I have a 2016 winnebago Navion, sprinter chassis, that has lost power to the trailer connector. no right, left, or running lights to trailer connector.
Submitted: 5 months ago.
Category: RV
Customer: replied 5 months ago.
Everything works on the motor home except the connector on the rear. Seems to be to be a or some blown fuses as he wired a jeep to be pulled by the motorhome and i think he just wired it wrong and blew fuses but not sure. just a little bit more info.
Expert:  peterpete190 replied 5 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. I would have the wiring that was installed checked to see if any wiring is found to be damaged in any way needing repaired or replaced.I have seen poor trailer wiring cause this type of fault here needing repaired or replaced to correct this issue.If this has already been checked and found to be o.k. let me know so we can continue from here. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 5 months ago.
This was connector was install by Winnebago during the building of the motor home. We have checked all wiring and connections and everything looks fine but we have no power which to meet seems to say that there is a fuse problem somewhere. we have found one fuse box under the dash and everything is ok there. is there another fuse box for chassis items somewhere? I suggest this question be given to an RV/Sprinter tech to get this question answered as to what the wiring troubles and possibilities are. Thanks for you help.
Expert:  peterpete190 replied 5 months ago.
Unfortunately I do not have access to the wiring diagrams or info on this here myself.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.Thanks Pete
Expert:  Randall replied 5 months ago.
Get back to me with the complete model number and I can get some wiring diagrams for you and help you track this down. All follow ups are included in our fee.

Related RV Questions