How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12669
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

Robert I have power to the switch both red and black but

Customer Question

hi Robert I have power to the switch both red and black but the light that is suppose to be lite on the switch dosent come on and I have power at all the conections behind toilet
Submitted: 11 months ago.
Category: RV
Customer: replied 11 months ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Robert replied 11 months ago.
Hi my name is***** me it sounds like the control box or the control switch is at fault. The voltage (red and black) should go to the control box and then the control box supplies power to the switch plate, I would say if you have voltage going to the switch plate it is at fault, if you have no voltage going to the switch plate from the control box then I would say that control box is bad... Hope this helps some... Robert
Expert:  Robert replied 11 months ago.
Please respond here, all the new questions you are opening I have to file a report on so you do not get charged again..... if you click HERE and see page 8 you can see the wiring, the main voltage goes to H-1 from there the power will go to H-2 which is the switch plate. I would have to say if you have voltage up at the switch plate then it is at fault, if you have NO voltage at the switch plate then H-1 is the problem. look the manual over as well, try the override and see if that works. Robert