How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gene Your Own Question
gene, RV Mechanic
Category: RV
Satisfied Customers: 1100
Experience:  28 yrs exp in the industry
Type Your RV Question Here...
gene is online now
A new question is answered every 9 seconds

I have a 6 kilowatt Onan generator on my Tiffin Allegro Breeze

Customer Question

I have a 6 kilowatt Onan generator on my Tiffin Allegro Breeze Class A RV. It has about 260 hours on it. (new in 2011) Oil changed 10 months ago. Bought it in November 2015.
When starting, normally, I press and hold the start button inside the coach . I hear a clicking sound that takes maybe 5-10 seconds, when cold, to start. Now there is no sound and it will not start. Could you tell me what is likely the problem and where is probably the best place to get it repaired, RV service center or Onan service center?
Thank you.
Submitted: 6 months ago.
Category: RV
Expert:  Randall replied 6 months ago.
Where are you located? When you try to start it does the set turn over or not?
Customer: replied 6 months ago.
There is no sound that would suggest that the starter is working like there was previously when it was functional. This seemed to have happened around the time that the "house batteries" went dead. They are now replaced and the 12 volt house system is working fine. I have tried to start the generator with the 12 volt system on and also with the RV engine running. Nothing....
Expert:  Randall replied 6 months ago.
Are you sure you didn't drop the generator lead off OR get it hooked up to the negative side of the batteries? This is easy to do. I would check that out first. That should be a red cable or one with a red end. And please included where you live in case we can't resolve this for you. You can take a small digital multimeter and check to see if you are actually getting power (12 VDC) to the set. That would tell you and direct your search.
Customer: replied 6 months ago.
Thanks! I swapped out the batteries myself. I tried to make sure I replaced the battery cables just like I found them but I will go back and check. I do have a multimeter. When you say 12 volts to the "set" do you mean to the generator. There is a red light that comes on at the generator that blinks three times which is code, apparently, for "needs service". I assumed it was getting power if it allowed for that light to come on. I can't get to the RV today however. May we continue this conversation after I get to it this week and take a look.
Expert:  Randall replied 6 months ago.
Yes, to the generator. It may be getting power, but you should check it. I wasn't sure if that flashing light was on the set or the remote. Let me know what you find.
Customer: replied 6 months ago.
Sure will. Thanks
Expert:  Randall replied 6 months ago.
You are welcome!

Related RV Questions