How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Reush Your Own Question
Michael Reush
Michael Reush, RV Technician
Category: RV
Satisfied Customers: 3249
Experience:  Serving the rv industry since 1977
Type Your RV Question Here...
Michael Reush is online now
A new question is answered every 9 seconds

I have a Atwood water heater in my 2008 Jayco camper. For

Customer Question

I have a Atwood water heater in my 2008 Jayco camper. For about two years I have had problems with the fault light indicator coming on and when it does, heater will not come on. At first just moving some wires at in front of the heater would clear the fault light. Later I have had to clean the terminal strip where the plug in are to correct the problem. Flipping the on and off switch rapidly several times would correct the problem. Now none of those things worked. Looking at the wiring diagram, both the thermostat and ECO device is connected to the fault light. Don't want to just start replacing parts and don't know how to troubleshooting. Got any ideas.
Submitted: 6 months ago.
Category: RV
Expert:  Michael Reush replied 6 months ago.
Hi, you need to replace the control module to repair your problem.............Michael

Related RV Questions