How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12140
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have an alarm going in endeavor diesel , it on when in g

Customer Question

I have an alarm going in endeavor diesel , it on when in gear
Submitted: 8 months ago.
Category: RV
Expert:  Robert replied 8 months ago.
Hi my name is ***** ***** could be a few things but my guess on this would be it is the parking brake sensor, it thinks the vehicle is in park when it is not, have seen this more then a few times on the Monaco's. The sensor would have wires going to it and many times it is right below the pull handle for the brakes, it will have an airline and the wires.Sometimes they are also located under the front cap area or in the front D/S compartment. I am not aware of anyway to bypass it.Other possible alarms would be if you have hydrulaic jacks make sure the fluid is all the way to the top of the tank with the jacks stored... Make sure if you have an antenna it is stowed. Also sometimes the low air sensors can fail have seen that on the monaco's when it rains it can cause them to go off due to not using weather tight connectors. Check the connectors at the sensors they will be located near the air tanks and have the DC wires going to it.From my experience this is going to be the parking brake sensor, when they fail it will cause an audible alarm to go off when you are driving. I would get a hold of Monaco on Monday and see if they can send you a print of the sensor and if they have a part number for you on that. Should be OK to drive if all your fluid levels are good and you are not getting any dash warnings. Hope this helps some, IF you have more questions or concerns please feel free to contact me... Robert