How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12155
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

Just bought my Keystone Montana with Atwood 8535 furnace.

Customer Question

Just bought my Keystone Montana with Atwood 8535 furnace. It is used but a 2015. I turned on the thermostat but heater will not come on. I have propane because stove top works. I have hit reset but nothing. I do not see anything else I can try to troubleshoot. I talked with previous owner and they said it worked great. It was just in for some warranty items and a roof repair but not an issue with furnace. The AC works great.
Submitted: 8 months ago.
Category: RV
Expert:  Robert replied 8 months ago.
Hi my name is***** the blower motor come on at all when you turn the T-stat on and raise the temp? As soon as you turn on the T-stat the fan should come on, then you should hear the electrode spark, if the fan is coming on can you hear it trying to spark? DO you have an outside access panel for the furnance OR just an intake/exhaust port?Robert
Customer: replied 8 months ago.
No fan comes on. There is an outside panel and I have it off now. I do not hear any attempts at sparking
Expert:  Robert replied 8 months ago.
OK So this is going to be a thermostat, circuit board or fan motor issue. When you turn the Thermostat on you should be getting power to the circuit board on a blue wire, click HERE and see the diagram,also notice the circuit breaker/on/off switch make sure to check that as well. IF you are getting nothing on the wire to the board then it sounds like a bad thermostat, if you are getting voltage to the board from the thermostat wire then the board might be bad, they do fail. Most RV shops have a special board tester and can tell if the board is bad, I might remove it and have it tested out. Need to determine if the thermostat is sending that signal to the board.
Customer: replied 8 months ago.
The AC works so am I wrong in thinking thermostat is okay?
Expert:  Robert replied 8 months ago.
Most likely but you do want to check the connections on the back of the T-stat, I would get a 12 volt test light, unlug the harness for the circuit board at the furnace and see if you have power on the blue wire when you turn the the thermostat ON.... Look at the diagram I sent it should help out... Hope this makes sense... Robert
Customer: replied 8 months ago.
Okay thanks
Expert:  Robert replied 8 months ago.
No problem if you need more help please let me know, follow ups are included, IF you are satisfied with my efforts please feel free to select a rating, it is the only way I get credit for helping... Robert
Expert:  Robert replied 8 months ago.
was just checking in to see if my answer helped? IF you have more questions or concerns please feel free to contact me... Robert