How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Joe Barfield Your Own Question
Joe  Barfield
Joe Barfield, RV Mechanic
Category: RV
Satisfied Customers: 1352
Experience:  36yrs.in Auto Industry, Aamco Trans.Master..
17290852
Type Your RV Question Here...
Joe Barfield is online now
A new question is answered every 9 seconds

I have a 2013 Winnebago Itasca Sunstar that starts but then

Customer Question

I have a 2013 Winnebago Itasca Sunstar that starts but then quits. It is under Ford Warranty, and has spent the last month at Palm Bay Ford. They replaced the PCM and it still had the same problem. They replaced the ignition switch, didn't fix it. Have had the chassis and both coach batteries replaced, didn't fix it. Had an RV Place, (A1 RV Malabar Florida) look at it three times. Still Starts and Quits. Has a Triton V-10.
Submitted: 8 months ago.
Category: RV
Customer: replied 8 months ago.
The problem is intermittent. Ford Dealer couldn't duplicate the problem for a week, but the following week I had to have AAA tow it to the Dealer. RV Repair place couldn't duplicate the problem, came to my house after it wouldn't start.
First time it happened was after a night of no hookup camping, started and quit 3 times (Fast Spin on starter), but then was dead. Aux boost started it right up. Went to breakfast but after it was totally dead. All accessories worked, wipers, horn fans. lights, etc. Started generator but still nothing. After 15 min on phone with AAA on hold, tried again & it started. Took it to Ford dealer, no luck. Also the RV repair place says I have to turn on the inverter after I start it to get the alternator to charge the chassis battery.
Expert:  Joe Barfield replied 8 months ago.

Hello ,This sounds more & more like its a fuel issue, id say possible fuel pump Thanks Joey

Customer: replied 8 months ago.
Was not the fuel pump. What now?