How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10329
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

Can you order a set of decals for a Tiffin by Allegro RV

Customer Question

Can you order a set of decals for a Tiffin by Allegro RV
Submitted: 9 months ago.
Category: RV
Expert:  Randall replied 9 months ago.

Are you talking about the whole coach?

Customer: replied 9 months ago.
or no depends on cost Mainly interested in the logo on front of coach
Customer: replied 9 months ago.
Also 12 volt on and off switch Up until now could hear solonid clik when switch turned on and off. No longer hear solonoid click I believe it is the solonoid inside the front of engine compartment If so where can I purchase this solonoid
Expert:  Randall replied 9 months ago.

Check the fuse on the solenoid......that is usually the cause. If this is an Intellitec solenoid, you can buy them online or at most any RV shop. About $75 or so and easy to install. Let me check on the decals. I will get back to you in the morning about those and the cost.

Expert:  Randall replied 8 months ago.

Sorry for the delay in getting back to you on the decals. Yes, they are still available for this. Contact Tiffin Customer Service at(###) ###-####and give them your VIN number and they can quote you a price for the ones you want. Hope that proves helpful here. Please get back to me if you need more later as all follow ups are included in our fee.

Expert:  Randall replied 8 months ago.

Just checking back in to see if you were able to get this resolved or do you need some additional input from me here?