How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10377
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

Appears I am only getting 11v to fuel pump on my onan 4000

Customer Question

Appears I am only getting 11v to fuel pump on my onan 4000 while cranking or running... Thoughts?
Submitted: 11 months ago.
Category: RV
Expert:  Randall replied 11 months ago.

What are you getting TO the start solenoid lead from the battery?

Customer: replied 11 months ago.
13v, 14v when plugged in
Customer: replied 11 months ago.
Gen won't stay running... I'm going to remove and clean carb best I can... Just installed a new Faucet Posi-flow fuel pump from Napa and it works great when 12v is applied via jump box... When cranking and hose is removed from carb no fuel is flowing... Makes me think power is not getting to fuel pump while cranking... Or is that normal to be less v while cranking...? Thanks
Expert:  Randall replied 11 months ago.

Are you still only getting 11 VDC to the new pump?

Customer: replied 11 months ago.
Watched it while cranking then during the 15seconds of run time and it started at 10v then made it to 12 once rpms picked up... So if pump is actually kicking on maybe run issues are just carb gunk related?..
Expert:  Randall replied 11 months ago.

Perhaps to some extent, but there should be a constant voltage to the pump all the time. That can be from any number of things..........a dirty connection or battery issues. Try to eliminate that first. If this has been sitting any length of time you ca get debris from the gas going bad.

Customer: replied 11 months ago.
By all the time u mean from the moment of pressing the start button? When u apply starter seems common to see a voltage drop momentarily while cranking in cars anyway like fan blower will stall while starting a car...
It has been sitting a lot I just bought motorhome from a guy didn't use it much for last 16 months
Expert:  Randall replied 11 months ago.

Then I suspect that the carb needs a good cleaning...........and you would get some minor voltage drop, but not usually 2 volts UNLESS the batteries are failing and you aren't plugged into shore power. I would test that as well. The charging voltage should be about 13.7 VDC, but just the converter alone can't supply enough amperage for starting this.

Expert:  Randall replied 11 months ago.

Just checking back it to see if you got this sorted out or do you still need some input from me here.