How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12802
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2005 class C Itasca with level jacks. All the

Customer Question

I have a 2005 class C Itasca with level jacks. All the control panel lights light up but when I press button to level nothing happens.
Submitted: 1 year ago.
Category: RV
Expert:  Robert replied 1 year ago.

Hi my name is Robert.....

On the control panel for the jacks it should have a name on it, need to know what it says. Also are the lights flashing at all? This might take some going back and forth...

Robert

Customer: replied 1 year ago.
I am not at motorhome. I thought I had owners manual with me but I appear to have forgotten it. All lights are lit on normally on panel when I press button to level nothing happens no flickering an anything. Only reaction I get is if I hit to store lights do flash but of course nothing changes because jacks are already stored.
Expert:  Robert replied 1 year ago.

OK

I can find out and then I will take a look at the system and respond back, might take a few mins.... Robert

Expert:  Robert replied 1 year ago.

OK

Have a feeling these might be aftermarket or installed after the unit was built, the manual mentions nothing about the leveling. I have done some installs on the class C units and normally we would put HWH jacks in but that is hard for me to say if that is what your unit has. IF you want to check or even better get me a picture of the control panel it should help, I am around daily and respond when I can..

Some basic things to check, make sure the RV is in park, the parking brake is set, if the are hydraulic make sure the level in the tank is all the way to the top with the jacks stored. Try running the jacks with the engine running and with the engine off. Beyond that I would need to know the manufacturer. IF they are HWH you will have a control box under the chassis with fuses in it, I would check that box for a blown fuse...... If needed please get back to me.... Robert